VS:IFC ClearIFCInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes all IFC data

FUNCTION IFC_ClearIFCInfo(
hObject :HANDLE) : BOOLEAN;
def vs.IFC_ClearIFCInfo(hObject):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object

Return Value

TRUE on success, FALSE indicates failure –incorrect handle or the object has no IFC data.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	ok : BOOLEAN;
begin
	hObject := FSActLayer;
	ok := IFC_ClearIFCInfo(hObject);
end;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = vs.IFC_ClearIFCInfo(hObject)

Version

Availability: from Vectorworks 2014