VS:IFC ClearIFCInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 30: Line 30:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<return>TRUE on success, FALSE indicates failure –incorrect handle or the object has no IFC data.</return>
===== Return Values =====
 
TRUE on success, FALSE indicates failure –incorrect handle or the object has no IFC data.
-----------------------------------------------------------------------------------------------------------
</remark>
<remark></remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:47, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes all IFC data

FUNCTION IFC_ClearIFCInfo(
hObject :HANDLE) : BOOLEAN;
def vs.IFC_ClearIFCInfo(hObject):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object

Return Value

TRUE on success, FALSE indicates failure –incorrect handle or the object has no IFC data.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	ok : BOOLEAN;
begin
	hObject := FSActLayer;
	ok := IFC_ClearIFCInfo(hObject);
end;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = vs.IFC_ClearIFCInfo(hObject)

Version

Availability: from Vectorworks 2014