VS:IFC ClearAllPsets

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes all IFC Psets.

FUNCTION IFC_ClearAllPsets(
hObject :HANDLE) : BOOLEAN;
def vs.IFC_ClearAllPsets(hObject):
    return BOOLEAN

Parameters

hObject HANDLE Handle to object.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	ok : BOOLEAN;
BEGIN
	hObject := FSActLayer;
	ok := IFC_ClearAllPsets(hObject);
END;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = vs.IFC_ClearAllPsets(hObject)

Version

Availability: from Vectorworks 2011