VS:IFC AttachPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function attaches a Pset to the specified object.

FUNCTION IFC_AttachPset(
hObject  : HANDLE;
inStrPsetName  : STRING) : BOOLEAN;
def vs.IFC_AttachPset(hObject, inStrPsetName):
    return BOOLEAN

Parameters

hObject HANDLE
inStrPsetName STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect pset name;

Remarks

Note that, in order to attach the desired pset, you have to attach IFC entity before.

Example

Assume we want an object to be exported as a space with attached Pset_SpaceFireSafetyRequirements (first we have to attach IfcSpace with mandatory and enumerational properties and then the pset):

IFC_SetIFCEntity(hSpace, 'IfcSpace');
IFC_SetEntityProp(hSpace, 'CompositionType', 'ELEMENT');
IFC_SetEntityProp(hSpace, 'InteriorOrExteriorSpace', 'INTERIOR');
IFC_AttachPset(hSpace, 'Pset_SpaceFireSafetyRequirements');

Version

Availability: 2010