VS:IFC AttachPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
This function attaches a Pset to the specified object.
Attaches a property set to the object</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION IFC_AttachPset(hObject: HANDLE; inStrPsetName: STRING) : BOOLEAN;
FUNCTION IFC_AttachPset(hObject:HANDLE; inStrPsetName:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 34: Line 33:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect pset name;
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
Note that, in order to attach the desired pset, you have to attach IFC entity before.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
Assume we want an object to be exported as a space with attached  Pset_SpaceFireSafetyRequirements (first we have to attach IfcSpace with mandatory and enumerational properties and then the pset):
<code lang="pas">
IFC_SetIFCEntity(hSpace, 'IfcSpace');
IFC_SetEntityProp(hSpace, 'CompositionType', 'ELEMENT');
IFC_SetEntityProp(hSpace, 'InteriorOrExteriorSpace', 'INTERIOR');
IFC_AttachPset(hSpace, 'Pset_SpaceFireSafetyRequirements');
</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: 2010
Availability: from Vectorworks 2014


</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Attaches a property set to the object

FUNCTION IFC_AttachPset(
hObject :HANDLE;
inStrPsetName :STRING) : BOOLEAN;
def vs.IFC_AttachPset(hObject, inStrPsetName):
    return BOOLEAN

Parameters

hObject HANDLE
inStrPsetName STRING

Version

Availability: from Vectorworks 2014