VS:HierLBItemClosed

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function is called when the user clicks on a container item to close it. It will remove items that are inside the container being closed.

PROCEDURE HierLBItemClosed(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
recursive :BOOLEAN);
def vs.HierLBItemClosed(dialogID, componentID, itemIndex, recursive):
    return None

Parameters

dialogID LONGINT The id of the dialog containing the list browser.
componentID LONGINT The id of the list browser.
itemIndex INTEGER The index of the item that was clicked on.
recursive BOOLEAN Whether to also close any containers inside the container that was clicked on.

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:HierLBItemOpened

VS Functions: [[VS:HierLBItemOpened]]