VS:HideClass

From Vectorworks Developer
Revision as of 21:39, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the class visibility of the specified class to hidden (invisible) status.

PROCEDURE HideClass(
className :STRING);
def vs.HideClass(className):
    return None

Parameters

className STRING Name of class.

Remarks

If you're hiding a class for the purpose of printing with that class turned off, you have to do a VS:ReDrawAll before calling the the DoMenuTextByName('Print',0) call, or else the class doesn't get hidden until after the script completes execution.

Example

VectorScript

HideClass('Dimension');

Python

vs.HideClass('Dimension')

Version

Availability: from All Versions

See Also

VS Functions:

VS:ShowClass

VS Functions: [[VS:ShowClass]]