VS:HasDim

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function HasDim returns TRUE if a line or arc object has dimension text associated with it, otherwise it returns FALSE.

FUNCTION HasDim(
h :HANDLE) : BOOLEAN;
def vs.HasDim(h):
    return BOOLEAN

Parameters

h HANDLE Handle to object.

Example

VectorScript

isDimension:=HasDim(HandleToObject);

Python

vs.Message(vs.HasDim(vs.FSActLayer()))

Version

Availability: from All Versions