VS:HasConstraint

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns whether the referenced object has a parametric constraint .

FUNCTION HasConstraint(
h :HANDLE) : BOOLEAN;
def vs.HasConstraint(h):
    return BOOLEAN

Parameters

h HANDLE Handle to object.

Remarks

(_c_, 2011 Oct. 06): This call returns true when there is an object of type 110 attached. This could mean an associated dimension, a join (for walls) or any user defined constraint. ONE constraint can be fetched using GetObjectVariableHandle(h, 703), but that brings nowhere, since there seems to be no way to fetch the related (constrained) object(s). Nevertheless fetching the first object of type 110 allows to parse for others using NextObj(my110obj) and checking for object type.

Any vertex constrained creates one such object type 110 for each of the objects involved.

Version

Availability: from VectorWorks 9.0