VS:HRotate

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure HRotate rotates the referenced object about a coordinate point location. rotationAngle is in degrees.

PROCEDURE HRotate(
h :HANDLE;
centerX,centerY :REAL;
rotationAngle :REAL);
def vs.HRotate(h, center, rotationAngle):
    return None

Parameters

h HANDLE Handle to object.
center REAL X-Y coordinates of center point of rotation.
rotationAngle REAL Angle of rotation.

Example

VectorScript

HRotate(objHd,3,5,60d);

Python

def Example():
	vs.HRotate(vs.FSActLayer(),3,5,60)

Example()

Version

Availability: from MiniCAD6.0