VS:HMoveForward

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Move the referenced object forward in the object stacking order. If toFront is TRUE, the object will be moved to the front of the stacking order.

PROCEDURE HMoveForward(
h :HANDLE;
toFront :BOOLEAN);
def vs.HMoveForward(h, toFront):
    return None

Parameters

h HANDLE Handle to object.
toFront BOOLEAN Move object to front of stacking order.

Remarks

It is possible using HMoveForward and HMoveBackward to re-order layers. But use caution. Do not set the toFront argument to TRUE -- it will delete the layer. Also, Peter Vandewalle claims that the layer can get deleted even if toFront is FALSE, if you keep sending it backward. (I could not confirm this.)

Example

VectorScript

PROCEDURE Example;
BEGIN
HMoveForward(FSActLayer, FALSE);
END;
RUN(Example);

Python

def Example():
	vs.HMoveForward(vs.FSActLayer(), False)

Example()

Version

Availability: from VectorWorks8.5