VS:HAngle

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function HAngle returns the angle of the referenced line or arc object.

FUNCTION HAngle(
h :HANDLE) : REAL;
def vs.HAngle(h):
    return REAL

Parameters

h HANDLE Handle to object.

Return Value

Returns angle in degrees.

Remarks

You can use this routines for getting the angle (slope) of a straight wall as well.

It will also detect the eventual reversion of the wall, consistent with the OIP.

On round walls the eventual reversion is NOT detected. Check if the wall is counterclockwise:

IF NOT GetObjectVariableBoo(wallH, 570) THEN
  wallRot := -wallrot;

For rotated rectangle and oval, the angle is in range [-180;180].

Example

VectorScript

PROCEDURE Example;
BEGIN
CallTool(-202);
Message(HAngle(FSActLayer));
END;
RUN(Example);

Python

def Example():
	vs.CallTool(-202)
	vs.Message(vs.HAngle(vs.FSActLayer()))

Example()

Version

Availability: from All Versions