VS:HAngle: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(corrected small typo)
Line 42: Line 42:
On round walls the eventual reversion is NOT detected. Check if the wall is counterclockwise:
On round walls the eventual reversion is NOT detected. Check if the wall is counterclockwise:
<code lang="pas">
<code lang="pas">
IF NOT GetObjectVariableBoo(wallH, 570) THEN
IF NOT GetObjectVariableBool(wallH, 570) THEN
   wallRot := -wallrot;
   wallRot := -wallrot;
</code>
</code>

Revision as of 09:47, 25 May 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function HAngle returns the angle of the referenced line or arc object.

FUNCTION HAngle(
h :HANDLE) : REAL;
def vs.HAngle(h):
    return REAL

Parameters

h HANDLE Handle to object.

Return Value

Returns angle in degrees.

Remarks

You can use this routines for getting the angle (slope) of a straight wall as well.

It will also detect the eventual reversion of the wall, consistent with the OIP.

On round walls the eventual reversion is NOT detected. Check if the wall is counterclockwise:

IF NOT GetObjectVariableBool(wallH, 570) THEN
  wallRot := -wallrot;

For rotated rectangle and oval, the angle is in range [-180;180].

Example

VectorScript

PROCEDURE Example;
BEGIN
CallTool(-202);
Message(HAngle(FSActLayer));
END;
RUN(Example);

Python

def Example():
	vs.CallTool(-202)
	vs.Message(vs.HAngle(vs.FSActLayer()))

Example()

Version

Availability: from All Versions