VS:GetZoom: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix typo)
m (Transfer Orso to _c_)
 
(One intermediate revision by the same user not shown)
Line 21: Line 21:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
(Orso, 2015.02.27): There are two possibilities to fetch the zoom. Suppose your zoom is 100%:
([[User:CBM-c-|_c_]], 2015.02.27): There are two possibilities to fetch the zoom. Suppose your zoom is 100%:
* GetZoom: returns 100
* GetZoom: returns 100
* GetPrefReal(500): returns 1
* GetPrefReal(500): returns 1

Latest revision as of 05:54, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetZoom returns the percentage of the zoom factor in the current document view.

FUNCTION GetZoom : REAL;
def vs.GetZoom():
    return REAL

Remarks

(_c_, 2015.02.27): There are two possibilities to fetch the zoom. Suppose your zoom is 100%:

  • GetZoom: returns 100
  • GetPrefReal(500): returns 1

[sd 8/18/98] Returns the percentage of the zoom factor in the current view. (100.0 would be the value if no zooming was done).

Version

Availability: from VectorWorks 8.0