VS:GetZatXY: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (1 revision)
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the Z height at a point X,Y
Returns the Z elevation of a point X,Y on the specified object. If hObject = NIL then searches all visible objects; hObject = layer - all objects on the layer</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetZatXY(hObject: HANDLE; X: REAL; Y: REAL; VAR outZ: REAL) : BOOLEAN;
FUNCTION GetZatXY(hObject:HANDLE; X:REAL; Y:REAL; VAR outZ:REAL) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 40: Line 39:
outZ
outZ
REAL
REAL
Output parameter.
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
If you pass NIL, it will search inside all the visible layers in the document, using layer elevation.
If you pass layer handle it searches everything in that layer.
 
If you pass object, it returns you Z of (x,y) on this object.
 
Return value: true if outZ is found; false otherwise.
 
Returned outZ always takes into accout the layer elevation.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Latest revision as of 17:35, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Z elevation of a point X,Y on the specified object. If hObject = NIL then searches all visible objects; hObject = layer - all objects on the layer

FUNCTION GetZatXY(
hObject :HANDLE;
X :REAL;
Y :REAL;
VAR outZ :REAL) : BOOLEAN;
def vs.GetZatXY(hObject, X, Y):
    return (BOOLEAN, outZ)

Parameters

hObject HANDLE
X REAL
Y REAL
outZ REAL

Version

Availability: from Vectorworks 2014