VS:GetZVals

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetZVals returns the Z (layer base elevation) and delta Z (layer thickness) values for the active layer.

PROCEDURE GetZVals(
VAR zVal :REAL;
VAR deltaZVal :REAL);
def vs.GetZVals():
    return (zVal, deltaZVal)

Parameters

zVal REAL Layer base elevation(above document ground plane).
deltaZVal REAL Layer thickness.

Remarks

Returns the Z and Delta Z values for the active layer.

[sd 8/14/98]

Example

VectorScript

PROCEDURE GetLayerHeights(layerHandle :handle; var baseElev, thickness :REAL);
BEGIN
GetLayerElevation(layerHandle, baseElev, thickness);
baseElev  := baseElev  / (25.4 / GetPrefReal(152));
thickness := thickness / (25.4 / GetPrefReal(152));
END;

Python


Version

Availability: from MiniCAD5.0