VS:GetWorkingPlaneN

From Vectorworks Developer
Revision as of 14:33, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the active working plane.

PROCEDURE GetWorkingPlaneN(
VAR outCenterPt_x :REAL;
VAR outCenterPt_y :REAL;
VAR outCenterPt_z :REAL;
VAR outNormal_x :REAL;
VAR outNormal_y :REAL;
VAR outNormal_z :REAL;
VAR outUVec_x :REAL;
VAR outUVec_y :REAL;
VAR outUVec_z :REAL);
def vs.GetWorkingPlaneN():
    return (outCenterPt, outNormal, outUVec)

Parameters

outCenterPt REAL Output. The working plane center.
outNormal REAL Output. The working plane normal.
outUVec REAL Output. The U Vector of the plane.

Version

Availability: from Vectorworks 2011