VS:GetWorkingPlaneMat

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the specified working plane matrix.

PROCEDURE GetWorkingPlaneMat(
refID :LONGINT;
VAR outCenterPt_x :REAL;
VAR outCenterPt_y :REAL;
VAR outCenterPt_z :REAL;
VAR outNormal_x :REAL;
VAR outNormal_y :REAL;
VAR outNormal_z :REAL;
VAR outUVec_x :REAL;
VAR outUVec_y :REAL;
VAR outUVec_z :REAL);
def vs.GetWorkingPlaneMat(refID):
    return (outCenterPt, outNormal, outUVec)

Parameters

refID LONGINT Reference ID of the working plane.
outCenterPt REAL Output. The working plane center.
outNormal REAL Output. The working plane normal.
outUVec REAL Output. The U Vector of the plane.

Version

Availability: from Vectorworks 2011