VS:GetWorkingPlaneMat

From Vectorworks Developer
Revision as of 14:33, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the specified working plane matrix.

PROCEDURE GetWorkingPlaneMat(
refID :LONGINT;
VAR outCenterPt :REAL;
VAR outNormal :REAL;
VAR outUVec :REAL);
def vs.GetWorkingPlaneMat(refID):
    return (outCenterPt, outNormal, outUVec)

Parameters

refID LONGINT Reference ID of the working plane.
outCenterPt REAL Output. The working plane center.
outNormal REAL Output. The working plane normal.
outUVec REAL Output. The U Vector of the plane.

Version

Availability: from Vectorworks 2011