VS:GetWorkingPlaneMat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:33, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the specified working plane matrix.

PROCEDURE GetWorkingPlaneMat(
refID :LONGINT;
VAR outCenterPt :REAL;
VAR outNormal :REAL;
VAR outUVec :REAL);
def vs.GetWorkingPlaneMat(refID):
    return (outCenterPt, outNormal, outUVec)

Parameters

refID LONGINT Reference ID of the working plane.
outCenterPt REAL Output. The working plane center.
outNormal REAL Output. The working plane normal.
outUVec REAL Output. The U Vector of the plane.

Version

Availability: from Vectorworks 2011