VS:GetWorkingPlane

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the location and orientation of the working plane.

PROCEDURE GetWorkingPlane(
VAR x :REAL;
VAR y :REAL;
VAR z :REAL;
VAR xRotation :REAL;
VAR yRotation :REAL;
VAR zRotation :REAL);
def vs.GetWorkingPlane():
    return (x, y, z, xRotation, yRotation, zRotation)

Parameters

x REAL X-coordinate of the working plane
y REAL Y-coordinate of the working plane
z REAL Z-coordinate of the working plane
xRotation REAL X-coordinate value of the rotation
yRotation REAL Y-coordinate value of the rotation
zRotation REAL Z-coordinate value of the rotation

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:SetWorkingPlane

VS Functions: [[VS:SetWorkingPlane]]