VS:GetWorkingFileId

From Vectorworks Developer
Revision as of 17:43, 16 September 2015 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the unique id for this Working File. This is not a filename.


Every Working File has a unique identifier. When layers are checked-out, they are reserved for not just a particular user, but also for a particular Working File Id.

The reserved layer can then only be edited in that specific Working File. If the user creates a second Working File and looks at the layer status, it will show in the second Working File as unavailable for checkout or edit, until it has been committed or released in the first file.

The specific value of the Working File Id is not meaningful, so it is not directly visible in any of the dialogs. It is used for the color highlighting of layer names in dialogs that show layer ownership.

FUNCTION GetWorkingFileId(
VAR uuid :STRING) : BOOLEAN;
def vs.GetWorkingFileId():
    return (BOOLEAN, uuid)

Parameters

uuid STRING Unique id for this working file

Return Value

True on success, false on failure or not Project Sharing file.

Version

Availability: from Vectorworks 2016

See Also

VS Functions:

VS:GetLayerProjectInfo

VS Functions: [[VS:GetLayerProjectInfo]]