VS:GetWallInsertLoc

From Vectorworks Developer
Revision as of 18:24, 15 September 2021 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the wall insert location of a symbol definition, plug-in object style, or plug-in object.

FUNCTION GetWallInsertLoc(
hObject :HANDLE) : INTEGER;
def vs.GetWallInsertLoc(hObject):
    return INTEGER

Parameters

hObject HANDLE The symbol definition, plug-in object style, or plug-in object.

Return Value

The wall insert location of the symbol definition, plug-in object style, or plug-in object.


-1 - Insert on the nearest edge of the wall
0 - Insert on the center of the wall
1 - Insert on the left edge of the wall
2 - Insert on the right edge of the wall
3 - Insert on the center of the wall core component
4 - Insert on the left edge of the wall core component
5 - Insert on the right edge of the wall core component

Version

Availability: from Vectorworks 2022

See Also

VS Functions:

VS:SetWallInsertLoc

VS Functions: [[VS:SetWallInsertLoc]]