VS:GetWallHoleTexturePart: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(Shorten OBJECT, reserved word)
 
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetWallHoleTexturePart(object:HANDLE) : INTEGER;
FUNCTION GetWallHoleTexturePart(obj:HANDLE) : INTEGER;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.GetWallHoleTexturePart(object):
def vs.GetWallHoleTexturePart(obj):
     return INTEGER
     return INTEGER
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The handle to the cutting object in the wall hole group of a symbol definition or plug-in object.
The handle to the cutting object in the wall hole group of a symbol definition or plug-in object.
Line 31: Line 31:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
The wall texture part.<BR>
The wall texture part.
<BR>
# The wall Holes texture part
0 - The wall Holes texture part<BR>
# The wall Left texture part
1 - The wall Left texture part<BR>
# The wall Right texture part
2 - The wall Right texture part</return>
 
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 20:01, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the wall texture part of an object in the wall hole group of a symbol definition or plug-in object. This is the wall texture part given to faces of the wall that are created by cutting a hole in the wall with the object.

FUNCTION GetWallHoleTexturePart(
obj :HANDLE) : INTEGER;
def vs.GetWallHoleTexturePart(obj):
    return INTEGER

Parameters

obj HANDLE The handle to the cutting object in the wall hole group of a symbol definition or plug-in object.

Return Value

The wall texture part.

  1. The wall Holes texture part
  2. The wall Left texture part
  3. The wall Right texture part

Version

Availability: from Vectorworks 2010

See Also

VS Functions:

VS:SetWallHoleTexturePart

VS Functions: [[VS:SetWallHoleTexturePart]]