VS:GetWallCompStartPts/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

壁の構成要素の始点の座標を取得します。

PROCEDURE GetWallCompStartPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :REAL;
VAR centerPoint :REAL;
VAR rightPoint :REAL);
def vs.GetWallCompStartPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE 壁または円弧壁のハンドル
componentIndex INTEGER 構成要素のインデックス
leftPoint REAL 構成要素の左端点
centerPoint REAL 構成要素の中心点
rightPoint REAL 構成要素の右端点

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompEndPts

VS Functions: [[VS:GetWallCompEndPts]]