VS:GetWallCompStartPts

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the start points of a wall component.

PROCEDURE GetWallCompStartPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :REAL;
VAR centerPoint :REAL;
VAR rightPoint :REAL);
def vs.GetWallCompStartPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint REAL Returns the left start point of the component
centerPoint REAL Returns the center start point of the component
rightPoint REAL Returns the right start point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompEndPts

VS Functions: [[VS:GetWallCompEndPts]]