VS:GetWallCompStartPts: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision: vw2015)
(it doesn't accept REAL, it only takes POINT)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE GetWallCompStartPts(wall:HANDLE; componentIndex:INTEGER; VAR leftPoint:REAL; VAR centerPoint:REAL; VAR rightPoint:REAL);
PROCEDURE GetWallCompStartPts(wall:HANDLE; componentIndex:INTEGER; VAR leftPoint:POINT; VAR centerPoint:POINT; VAR rightPoint:POINT);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 34: Line 34:
<line>
<line>
leftPoint
leftPoint
REAL
POINT
Returns the left start point of the component
Returns the left start point of the component
</line>
</line>
<line>
<line>
centerPoint
centerPoint
REAL
POINT
Returns the center start point of the component
Returns the center start point of the component
</line>
</line>
<line>
<line>
rightPoint
rightPoint
REAL
POINT
Returns the right start point of the component
Returns the right start point of the component
</line>
</line>

Latest revision as of 08:24, 4 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the start points of a wall component.

PROCEDURE GetWallCompStartPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :POINT;
VAR centerPoint :POINT;
VAR rightPoint :POINT);
def vs.GetWallCompStartPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint POINT Returns the left start point of the component
centerPoint POINT Returns the center start point of the component
rightPoint POINT Returns the right start point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompEndPts

VS Functions: [[VS:GetWallCompEndPts]]