VS:GetWallCompEndPts

From Vectorworks Developer
Revision as of 08:34, 4 February 2016 by CBM-c- (talk | contribs) (only accepts POINT, not REAL)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the end points of a wall component.

PROCEDURE GetWallCompEndPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :POINT;
VAR centerPoint :POINT;
VAR rightPoint :POINT);
def vs.GetWallCompEndPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint POINT Returns the left end point of the component
centerPoint POINT Returns the center end point of the component
rightPoint POINT Returns the right end point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompStartPts

VS Functions: [[VS:GetWallCompStartPts]]