VS:GetWallCompEndPts

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the end points of a wall component.

PROCEDURE GetWallCompEndPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :REAL;
VAR centerPoint :REAL;
VAR rightPoint :REAL);
def vs.GetWallCompEndPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint REAL Returns the left end point of the component
centerPoint REAL Returns the center end point of the component
rightPoint REAL Returns the right end point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompStartPts

VS Functions: [[VS:GetWallCompStartPts]]