VS:GetWallCompEndPts: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision: vw2015)
(only accepts POINT, not REAL)
 
Line 11: Line 11:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE GetWallCompEndPts(wall:HANDLE; componentIndex:INTEGER; VAR leftPoint:REAL; VAR centerPoint:REAL; VAR rightPoint:REAL);
PROCEDURE GetWallCompEndPts(wall:HANDLE; componentIndex:INTEGER; VAR leftPoint:POINT; VAR centerPoint:POINT; VAR rightPoint:POINT);
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 34: Line 34:
<line>
<line>
leftPoint
leftPoint
REAL
POINT
Returns the left end point of the component
Returns the left end point of the component
</line>
</line>
<line>
<line>
centerPoint
centerPoint
REAL
POINT
Returns the center end point of the component
Returns the center end point of the component
</line>
</line>
<line>
<line>
rightPoint
rightPoint
REAL
POINT
Returns the right end point of the component
Returns the right end point of the component
</line>
</line>

Latest revision as of 08:34, 4 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the end points of a wall component.

PROCEDURE GetWallCompEndPts(
wall :HANDLE;
componentIndex :INTEGER;
VAR leftPoint :POINT;
VAR centerPoint :POINT;
VAR rightPoint :POINT);
def vs.GetWallCompEndPts(wall, componentIndex):
    return (leftPoint, centerPoint, rightPoint)

Parameters

wall HANDLE The wall or round wall
componentIndex INTEGER The component index
leftPoint POINT Returns the left end point of the component
centerPoint POINT Returns the center end point of the component
rightPoint POINT Returns the right end point of the component

Return Value

None

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetWallCompStartPts

VS Functions: [[VS:GetWallCompStartPts]]