VS:GetWSSubrowCount: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a count of displayed subrows for a specified database row.

PROCEDURE GetWSSubrowCount(
worksheet :HANDLE;
databaseRow :INTEGER;
VAR numSubrows :INTEGER);
def vs.GetWSSubrowCount(worksheet, databaseRow):
    return numSubrows

Parameters

worksheet HANDLE Handle to worksheet.
databaseRow INTEGER Database row to be queried.
numSubrows INTEGER Number of displayed subrows.

Remarks

Gets the number of subrows associated with the specified worksheet database row.

WARNING: Because database subrow cells and their contents are dynamically created based on the current database of objects and the current critieria string any return values from this function are not guaranteed to be correct beyond this function call. Use this function carefully and at your own risk.

Version

Availability: from VectorWorks9.0