VS:GetWSMergedCellRange

From Vectorworks Developer
Revision as of 22:21, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the range of cells covered by the specified cell. Returns true if the specified cell is a merged cell.

FUNCTION GetWSMergedCellRange(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR topRow :INTEGER;
VAR leftColumn :INTEGER;
VAR bottomRow :INTEGER;
VAR rightColumn :INTEGER) : BOOLEAN;
def vs.GetWSMergedCellRange(worksheet, row, column):
    return (BOOLEAN, topRow, leftColumn, bottomRow, rightColumn)

Parameters

worksheet HANDLE Worksheet on which function is to operate.
row INTEGER Row index of merged cell from which to get the covered range.
column INTEGER Column index of merged cell from which to get the covered range.
topRow INTEGER Top row index of merged cell range.
leftColumn INTEGER Left column index of merged cell range.
bottomRow INTEGER Bottom row index of merged cell range.
rightColumn INTEGER Right column index of merged cell range.

Return Value

'true' if specified cell is a merged cell

'false' otherwise.

Version

Availability: from VectorWorks12.5