VS:GetWSCellString: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the displayed string value of a cell in the referenced worksheet.

PROCEDURE GetWSCellString(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR cellString :STRING);
def vs.GetWSCellString(worksheet, row, column):
    return cellString

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Row of cell to be queried.
column INTEGER Column of cell to be queried.
cellString STRING The string value contained in the worksheet cell.

Remarks

Gets the specified worksheet cell's displayed string.

If the cell contains a string, the displayed string IS that string. If the cell contains a number, the displayed string is that number PLUS any formatting applied to that number. Use IsWSCellString and/or IsWSCellNumber to determine what type of value the cell actually contains. Use GetWSCellValue to retrieve actual numerical value without formatting from a cell that contains a number.

Version

Availability: from VectorWorks 9.0

See Also

IsWSCellString, IsWSCellStringN, IsWSCellNumber, GetWSCellValue

[[VS:IsWSCellString | IsWSCellString]], [[VS:IsWSCellStringN | IsWSCellStringN]], [[VS:IsWSCellNumber | IsWSCellNumber]], [[VS:GetWSCellValue | GetWSCellValue]]