VS:GetWSCellNumberFormat

From Vectorworks Developer
Revision as of 07:31, 9 May 2022 by CBM-c- (talk | contribs) (improve flag list)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the numeric formatting of a cell in the referenced worksheet.

Specific index values for numeric formats and accuracy are listed in the Appendix.

PROCEDURE GetWSCellNumberFormat(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR style :INTEGER;
VAR accuracy :INTEGER;
VAR leaderString :STRING;
VAR trailerString :STRING);
def vs.GetWSCellNumberFormat(worksheet, row, column):
    return (style, accuracy, leaderString, trailerString)

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Row of cell to be queried.
column INTEGER Column of cell to be queried.
style INTEGER Numeric format style index.
accuracy INTEGER Numeric accuracy / secondary format index.
leaderString STRING Leader string (where applicable).
trailerString STRING Trailer string (where applicable).

Remarks

(_c_ 2022.05.09):

Number Format constants:

flag style
0 general
1 decimal
2 decimal with commas
3 scientific
4 fractional
5 dimension
6 angle
For angle, the accuracy displays the angle format as in the pull-down menu list,

whereby the choices 1 to 3 are degrees, the rest decimal.

7 date
For date, the accuracy displays the date format as in the pull-down menu list.

Warning: the returned flags don't correspond the the pull-down index.

8 boolean
11 dimension area
12 dimension volume
13 text
14 percentage

Version

Availability: from VectorWorks 9.0