VS:GetWSCellNumberFormat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
mNo edit summary
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the numeric formatting of a cell in the referenced worksheet.

Specific index values for numeric formats and accuracy are listed in the Appendix.

PROCEDURE GetWSCellNumberFormat(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR style :INTEGER;
VAR accuracy :INTEGER;
VAR leaderString :STRING;
VAR trailerString :STRING);
def vs.GetWSCellNumberFormat(worksheet, row, column):
    return (style, accuracy, leaderString, trailerString)

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Row of cell to be queried.
column INTEGER Column of cell to be queried.
style INTEGER Numeric format style index.
accuracy INTEGER Numeric accuracy / secondary format index.
leaderString STRING Leader string (where applicable).
trailerString STRING Trailer string (where applicable).

Remarks

Number Format constants:

style value meaning of accuracy General = 0 FixDecimal = 1 number of decimal places DecwCommas = 2 number of decimal places Scientific = 3 number of decimal places Fractional = 4 largest displayed denominator Dimension = 5 Angle = 6 corresponds to angular accuracy in units dialog Date = 7 Conditonal = 8

Version

Availability: from VectorWorks9.0