VS:GetWSCellNumberFormat: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(expand with date formats)
(expand)
Line 68: Line 68:
Number Format constants:
Number Format constants:
{| class="wikitable"
{| class="wikitable"
! flag !! style !!
! Flag !! Style !!
|-
|-
| 0 || general
| 0 || general
Line 90: Line 90:
| 7 || date
| 7 || date
|-
|-
| colspan="2" | For date, the accuracy displays the date format as in the pull-down menu list.  
| colspan="2" | For date, the accuracy displays the date format as in the pull-down menu.  


Warning: the returned flags don't correspond the pull-down indexes.
Warning:  
* the format depends on the system settings.
:: Example: flag 33 shows as dd/mm/yy in the pull-down menu, but resolves as dd.mm.yy in my German system.
* the returned flags don't correspond the pull-down indexes. See list:


{| class="wikitable"
{| class="wikitable"

Revision as of 07:53, 9 May 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the numeric formatting of a cell in the referenced worksheet.

Specific index values for numeric formats and accuracy are listed in the Appendix.

PROCEDURE GetWSCellNumberFormat(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR style :INTEGER;
VAR accuracy :INTEGER;
VAR leaderString :STRING;
VAR trailerString :STRING);
def vs.GetWSCellNumberFormat(worksheet, row, column):
    return (style, accuracy, leaderString, trailerString)

Parameters

worksheet HANDLE Handle to worksheet.
row INTEGER Row of cell to be queried.
column INTEGER Column of cell to be queried.
style INTEGER Numeric format style index.
accuracy INTEGER Numeric accuracy / secondary format index.
leaderString STRING Leader string (where applicable).
trailerString STRING Trailer string (where applicable).

Remarks

(_c_ 2022.05.09):

Number Format constants:

Flag Style
0 general
1 decimal
2 decimal with commas
3 scientific
4 fractional
5 dimension
6 angle
For angle, the accuracy displays the angle format as in the pull-down menu list,

whereby the choices 1 to 3 are degrees, the rest decimal.

7 date
For date, the accuracy displays the date format as in the pull-down menu.

Warning:

  • the format depends on the system settings.
Example: flag 33 shows as dd/mm/yy in the pull-down menu, but resolves as dd.mm.yy in my German system.
  • the returned flags don't correspond the pull-down indexes. See list:
Flag Date Format
9 Jan-04
1 1.24.04
30 01.24.1904
2 1.24.04 21:34
14 1.24.04 21:34:14
8 24-Jan
3 24.1.04
7 24-Jan-04
33 24.01.04
35 24.01.1904
4 24.1.04 21:34
23 24.1.04 21:34:14
34 24.01.04 21:34:14
36 24.01.1904 21:34:14
5 04.1.24
29 19040124
31 1904-01-24
6 04.1.24 21:34
28 04.1.24 21:34:14
32 19040124213414
10 21:34
11 21:34:14
12 21:34
13 21:34:14
15 Sunday, January 24, 1904
16 Sunday, January 24, 1904 21:34:14
17 Sun, Jan 24, 1904
18 Sun, Jan 24, 1904 21:34:14
19 Sunday, 24 January 1904
20 Sunday, 24 January 1904 21:34:14
21 Sun, 24 Jan 1904
22 Sun, 24 Jan 1904 21:34:14
24 Sunday, 1904 January 24
25 Sunday, 1904 January 24 21:34:14
26 Sun, 1904 Jan 24
27 Sun, 1904 Jan 24 21:34:14
8 boolean
11 dimension area
12 dimension volume
13 text
14 percentage

Version

Availability: from VectorWorks 9.0