VS:GetWSCellFill: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:33, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill style and color of a cell in the referenced worksheet

PROCEDURE GetWSCellFill(
worksheet :HANDLE;
row :INTEGER;
column :INTEGER;
VAR style :INTEGER;
VAR bgcolor :LONGINT;
VAR fgcolor :LONGINT;
VAR fillpattern :INTEGER);
def vs.GetWSCellFill(worksheet, row, column):
    return (style, bgcolor, fgcolor, fillpattern)

Parameters

worksheet HANDLE Handle to worksheet
row INTEGER Row of cell to be queried
column INTEGER Column of cell to be queried
style INTEGER Cell fill style constant
bgcolor LONGINT Cell background color index
fgcolor LONGINT Cell foreground color index
fillpattern INTEGER Cell pattern index

Remarks

bgcolor - cell background color (0 if none)

fgcolor - cell foreground color (0 if none) fillpattern - cell fill pattern index (-1 if none)

Fill style constants: no fill = 0 solid fill= 1 pattern fill= 2

Version

Availability: from VectorWorks12.0