VS:GetWSAutoRecalcState/ja

From Vectorworks Developer
Revision as of 14:33, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定したワークシートがセル編集時に自動再計算する設定かどうかを返します。

In order to improve speed when editing mutiple cells one after the other or in a loop, it is highly recommended to turn this flag off prior to the edits and restore it, then recalculate the worksheet when all the edits are completed.

FUNCTION GetWSAutoRecalcState(
worksheet :HANDLE) : BOOLEAN;
def vs.GetWSAutoRecalcState(worksheet):
    return BOOLEAN

Parameters

worksheet HANDLE ワークシートのハンドル

Example

{Save the current AutoRecalc state}
state := GetWSAutoRecalcState(h);

{Turn off worksheet Auto Recalculation}
SetWSAutoRecalcState(h,false);

{Execute worksheet edit operations ....}

{Restore AutoRecalc state}
SetWSAutoRecalcState(h, state);

{Recalculate the worksheet}
RecalculateWS(h);

Version

利用可能バージョン: Vectorworks 2009

See Also

関連関数:

VS:SetWSAutoRecalcState | VS:RecalculateWS

関連関数:

[[VS:SetWSAutoRecalcState]]

| [[VS:RecalculateWS]]