VS:GetViewMatrix

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets view matrix for layer or viewport object.

FUNCTION GetViewMatrix(
objectHandle :HANDLE;
VAR offsetX,offsetY,offsetZ :REAL;
VAR rotationXAng :REAL;
VAR rotationYAng :REAL;
VAR rotationZAng :REAL) : BOOLEAN;
def vs.GetViewMatrix(objectHandle):
    return (BOOLEAN, offset, rotationXAng, rotationYAng, rotationZAng)

Parameters

objectHandle HANDLE
offset REAL
rotationXAng REAL
rotationYAng REAL
rotationZAng REAL

Version

Availability: from VectorWorks10.5