VS:GetViewMatrix

From Vectorworks Developer
Revision as of 14:33, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets view matrix for layer or viewport object.

FUNCTION GetViewMatrix(
objectHandle :HANDLE;
VAR offsetX,offsetY,offsetZ :REAL;
VAR rotationXAng :REAL;
VAR rotationYAng :REAL;
VAR rotationZAng :REAL) : BOOLEAN;
def vs.GetViewMatrix(objectHandle):
    return (BOOLEAN, offset, rotationXAng, rotationYAng, rotationZAng)

Parameters

objectHandle HANDLE
offset REAL
rotationXAng REAL
rotationYAng REAL
rotationZAng REAL

Version

Availability: from VectorWorks10.5