VS:GetVectorFill

From Vectorworks Developer
Revision as of 21:56, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetVectorFill returns if the referenced object has a vector fill assigned.

FUNCTION GetVectorFill(
theObj :HANDLE;
VAR hatchName :STRING) : BOOLEAN;
def vs.GetVectorFill(theObj):
    return (BOOLEAN, hatchName)

Parameters

theObj HANDLE Handle to object.
hatchName STRING Returns name of assigned vector fill pattern.

Remarks

Returns true if the theObj has a vectorfill. hatchName holds the name of the vector fill that theObj has.


This routine will also return names of Gradient or Image Fill definitions applied to theObj.

Version

Availability: from MiniCAD7.0.1