VS:GetVSVar: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Procedure SysBeep uses the current system prompt sound to alert the user.
This is python only function. The function stores a named VectorScript variable value into the python variable.


This function work in the context when a VectorScript executes a python sub-script and allows data communication between the two languages. See [[VS:SetVSVar]] for the reverse data transfer.
This function is useful when using [[VS:PythonExecute|PythonExecute]] or [[VS:PythonBeginContext|PythonBeginContext]]
</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
PROCEDURE SysBeep;
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.SysBeep():
def vs.GetVSVar(vsName):
     return None
     return Any
</funcDef>
</funcDef>
</def>
</def>
-----------------------------------------------------------------------------------------------------------
<params>
<lineList ident=1>
<line>
vsName
STRING
The name of the VectorScript variable that will provide the value to be returned.
</line>
</lineList>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
Returns the value of the named VectorScript variable. The type will depend on the actual variable. See the remarks of [[VS:SetVSVar]] for more info.
</return>
-----------------------------------------------------------------------------------------------------------
<remark>
</remark>
-----------------------------------------------------------------------------------------------------------
<sample>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


</version>
</version>
Line 29: Line 57:
</vwDoc>
</vwDoc>


[[Category:VS Function Reference|SysBeep]]
[[Category:VS Function Reference|GetVSVar]]
[[Category:VS Function Reference:Python Utility|SysBeep]]
[[Category:VS Function Reference:Python Utility|GetVSVar]]

Revision as of 18:56, 25 August 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This is python only function. The function stores a named VectorScript variable value into the python variable.

This function work in the context when a VectorScript executes a python sub-script and allows data communication between the two languages. See VS:SetVSVar for the reverse data transfer.

This function is useful when using PythonExecute or PythonBeginContext

def vs.GetVSVar(vsName):
    return Any

Parameters

vsName STRING The name of the VectorScript variable that will provide the value to be returned.

Return Value

Returns the value of the named VectorScript variable. The type will depend on the actual variable. See the remarks of VS:SetVSVar for more info.

Version

Availability: from Vectorworks 2014