VS:GetVPGroupParent

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the viewport that is the parent of specified viewport group.

FUNCTION GetVPGroupParent(
groupHandle :HANDLE) : HANDLE;
def vs.GetVPGroupParent(groupHandle):
    return HANDLE

Parameters

groupHandle HANDLE handle to a viewport group (crop, annotation, etc)

Return Value

Returns a handle to the viewport object (type 122) that is the parent of the specified group, or nil if unsuccessful.

Version

Availability: from VectorWorks11.0