VS:GetVPClOvrdFillFore/ja

From Vectorworks Developer
Revision as of 09:56, 16 January 2014 by Kimura (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ビューポートクラスの前景色を返します。 色は0~65535の三つのRGB値で返されます。

PROCEDURE GetVPClOvrdFillFore(
viewportHandle :HANDLE;
className :STRING;
VAR colorRV :LONGINT;
VAR colorGV :LONGINT;
VAR colorBV :LONGINT);
def vs.GetVPClOvrdFillFore(viewportHandle, className):
    return (colorRV, colorGV, colorBV)

Parameters

viewportHandle HANDLE ビューポートへのハンドル
className STRING クラスの名前
colorRV LONGINT 色の赤要素
colorGV LONGINT 色の緑要素
colorBV LONGINT 色の青要素

Return Value

指定のビューポートクラスがある場合TRUEを返します。
ビューポートクラスがない場合、クラス、ビューポートが不適切な場合FALSEを返します。

Version

Availability: from Vectorworks 2014

See Also

VS Functions:

VS:SetVPClOvrdFillFore

VS Functions: [[VS:SetVPClOvrdFillFore]]