VS:GetTypeN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(No difference)

Revision as of 14:33, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the type index of the referenced planar or screen object.

A complete listing of supported object types may be found in the Appendix.

FUNCTION GetTypeN(
h :HANDLE) : INTEGER;
def vs.GetTypeN(h):
    return INTEGER

Parameters

h HANDLE Handle to object.

Remarks

Rgm [2012.05.16]: Note that to distinguish a Sheet Layer from a Design Layer, you need to check object variable 154 (ovLayerType), eg. GetObjectVariableInt(layerHd,154). If 1, then it's a Design Layer. If 2, then it's a Sheet Layer. GetTypeN will return 31 (kLayerNode) for both types.

Version

Availability: from Vectorworks 2011

See Also

VS Functions:

VS:GetType

VS Functions: [[VS:GetType]]