VS:GetTopPlan2DComp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(fix table)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Gets the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object<BR>
Gets the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object.
                          Table - components:<BR>
 
Component Constant<BR>
 
Top 0<BR>
''Table - components''
Top and Bottom Cut                 1</desc>
{| class = "wikitable_c"
! Constant !! component
|-
| 0 || Top
|-
| 1 || Top and Bottom Cut
|}
 
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:49, 14 February 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object.


Table - components

Constant component
0 Top
1 Top and Bottom Cut
FUNCTION GetTopPlan2DComp(
objectHandle :HANDLE) : INTEGER;
def vs.GetTopPlan2DComp(objectHandle):
    return INTEGER

Parameters

objectHandle HANDLE Handle to the object.

Return Value

Returns the 2D component that is shown in Top/Plan view for a symbol definition or plug-in object.

Version

Availability: from Vectorworks 2019

See Also

VS Functions:

VS:SetTopPlan2DComp | VS:Get2DComponentGroup | VS:Set2DComponentGroup

VS Functions:

[[VS:SetTopPlan2DComp]] | [[VS:Get2DComponentGroup]]

| [[VS:Set2DComponentGroup]]