VS:GetTextStyleRefN

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

GetTextStyleRefN returns the text style reference at a specified position within the text object. Reference 0 means Un-Styled.


If the text object is using class text style, this returns the effective style. You should use the *TextStyleByClass* functions to check and preserve by-class behavior.

FUNCTION GetTextStyleRefN(
objectId :HANDLE;
position :INTEGER) : LONGINT;
def vs.GetTextStyleRefN(objectId, position):
    return LONGINT

Parameters

objectId HANDLE handle to text object
position INTEGER Position in text string, zero-based.

Return Value

Returns the text style reference id for the requested character postion

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetTextStyleRef | VS:GetTextStyleRef | VS:SetTextStyleRefN | VS:GetTextStyleRefN | VS:SetTextStyleByClass | VS:SetTextStyleByClassN | VS:IsTextStyleByClass | VS:IsTextStyleByClassN

VS Functions:

[[VS:SetTextStyleRef]] | [[VS:GetTextStyleRef]] | [[VS:SetTextStyleRefN]] | [[VS:GetTextStyleRefN]] | [[VS:SetTextStyleByClass]] | [[VS:SetTextStyleByClassN]] | [[VS:IsTextStyleByClass]]

| [[VS:IsTextStyleByClassN]]