VS:GetTextFont

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTextFont returns the font of the referenced text object at a specified position in the string.

The position is in a range between 0 and 32767, representing a character position in the text string. An index of 0 refers to the first character in the string.

FUNCTION GetTextFont(
objectHd :HANDLE;
Position :INTEGER) : INTEGER;
def vs.GetTextFont(objectHd, Position):
    return INTEGER

Parameters

objectHd HANDLE Handle to text object.
Position INTEGER Position in text string.

Example

VectorScript

fontID:=GetTextFont(handleToText,2);

Python

fontID = vs.GetTextFont(handleToText,2)

Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:GetFontName | VS:GetFontID

VS Functions:

[[VS:GetFontName]]

| [[VS:GetFontID]]