VS:GetTextFont

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetTextFont returns the font of the referenced text object at a specified position in the string.

The position is in a range between 0 and 32767, representing a character position in the text string. An index of 0 refers to the first character in the string.

FUNCTION GetTextFont(
objectHd :HANDLE;
Position :INTEGER) : INTEGER;
def vs.GetTextFont(objectHd, Position):
    return INTEGER

Parameters

objectHd HANDLE Handle to text object.
Position INTEGER Position in text string.

Example

VectorScript

fontID:=GetTextFont(handleToText,2);

Python

fontID = vs.GetTextFont(handleToText,2)

Version

Availability: from MiniCAD6.0

See Also

VS Functions:

VS:GetFontName | VS:GetFontID

VS Functions:

[[VS:GetFontName]]

| [[VS:GetFontID]]