VS:GetTexSpacePartID

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetTexSpacePartID returns the parent of the referenced texture space in an expanded object (walls or roofs).

Table - Texture Space Objects
Object Constant
Primary 0
Secondary 1
Tertiary 2
FUNCTION GetTexSpacePartID(
textureSpace :HANDLE) : INTEGER;
def vs.GetTexSpacePartID(textureSpace):
    return INTEGER

Parameters

textureSpace HANDLE Handle to texture space.

Remarks

Returns which part (0 = Primary, 1 = Secondary, 2 = Tertiary) of the object this space belongs to (for expanded walls and roofs).

Note: GetTexMapXXX routines replace the older GetTexSpaceXXX routines. It is recommended that all developers transition to the newer versions.

Version

Availability: from VectorWorks 8.0